Exchange Server 2016 und Umlaute – viel Spaß

Neulich in diesem Theater: Ein Kunde rief an, weil er Probleme in Verbindung mit seinem Exchange Server 2016 und Umlaute hatte; ein Benutzerpostfach konnte über die Exchange Admin Console (ehemals Exchange Control Panel, /ECP) nicht erzeugt werden.

Details, bitte

Der Nutzer, nennen wir ihn Müllertest, war durch Kopieren eines vorhandenen Nutzers erzeugt worden. Danach sollte er ein Postfach bekommen, was das ECP mit dem Fehler ablehnte, dass die SMTP-Adresse ungültig sei. Dabei wurde der Buchstabe “ü” durch ein “y” mit Trema ersetzt:

Fehlermeldung von Exchange Server 2016 und Umlaute mit fehlerhafter Darstellung
Die Fehlermeldung mit vertauschtem Umlaut im ECP

Und nun?

Um die Anzahl der potenziellen Fehlerquellen zu erhöhen, nutzte der Kunde seinen Mac. Das ECP wurde über Chrome aufgerufen, um den Nutzer anzulegen. Die falsche Anzeige lies daher zuerst auf einen Codierungsfehler schließen. Wir wissen ja leider, wie es bisweilen mit der Interoperabilität von Microsoft und Apple aussieht…

In der Folge stellten wir fest, dass der Fehler mit Safari, Chrome und Firefox unter Mac auftritt – aber auch unter Windows 10 mit Edge, IE, Firefox und Chrome. Damit war der Codierungsfehler vom Tisch.

Letztlich bliebt nur die Möglichkeit, über die Powershell mit enable-mailbox die Mailbox zu erzeugen.

Parallelen

In diesem Kontext fiel auf, dass bei der Migration von Exchange 2013 nach 2016 das seltsame “y” mit Trema (so nennt man die beiden Pünktchen) auch schon in Fehlermeldungen auftrat und Nutzer mit Umlauten im Namen nicht migriert werden konnten. Damals wurden die smtp-Adressen händisch temporär verändert und nach der Migration wieder zurückgestellt

Pech gehabt?

Nach viel Recherche konnte schließlich im Technet ein Thread gefunden werden, der einen Bug in Exchange 2016 CU5 thematisiert: Umlaute und Sonderzeichen wie ß werden nicht sauber verarbeitet, führen zu der Oben gezeigten Fehlermeldung und verhindern wegen unzulässiger Zeichen die Migration zwischen Datenbanken.

Im Grunde ist der Kunde zur falschen Zeit migriert: er ist direkt mit Exchange 2016 CU5 eingestiegen. Ein Quartal später (mit dem Cumulative Update 6 war der Fehler schon längst wieder gefixt).

Ironischerweise wurde nach der schwierigen Migration bis auf Weiteres keine Installation kumulativer Updates in Betracht gezogen, da die Schwierigkeiten im Handling der Nutzermailboxen mit Sonderzeichen die Migration zeitlich völlig hatten aus dem Ruder laufen lassen.

Nach aktueller Recherche kann man Stand heute (13.09.2018) davon ausgehen, dass Exchange Server 2016 und Umlaute in Benutzernamen sich wieder vertragen.

Bleibt letztlich “nur” wieder der schale Beigeschmack offenbar unzureichender Tests.

Schreibe einen Kommentar